"A problem occurred while trying to weigh using the scale: No value returned from the scale, please check it is attached correctly." message in SendSuite Live

If the message "A problem occurred while trying to weigh using the scale: No value returned from the scale, please check it is attached correctly." appears when trying to weigh something, there is an issue with the Client Scale Component XML file.
Products affected: SendSuiteĀ® Live

Issue

When trying to weigh something in SendSuite Live using DeviceHub, the message "A problem occurred while trying to weigh using the scale: No value returned from the scale, please check it is attached correctly." appears.

Cause

There is an issue with the Client Scale Component XML file.

Resolution

  1. Open the System Tray (small icons near the clock).
  2. Right-click on the DeviceHub icon and select SendSuite Live Scale Configuration.
  3. Change the Interface Type from USB to Internal Test Mode Only. Ensure that the Scale Type changes to Demo Scale.
  4. Select OK.
  5. Open the System Tray.
  6. Right-click on the DeviceHub icon and select SendSuite Live Scale Configuration.
  7. Change the Interface Type back to USB.
  8. Using the menu next to the Scale Type setting, verify the attached scale.
  9. Select OK.
  10. Refresh your SendSuite Live Project page.
  11. Verify that you are now able to get a rate in SendSuite Live.

UPDATED: June 16, 2023